<!DOCTYPE html><html lang="en"><head><script>window.currentUser = null;</script><title itemprop="name">The Modern Javascript Tutorial</title><meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=yes, minimum-scale=1.0"><meta name="apple-mobile-web-app-capable" content="yes"><script>if (window.devicePixelRatio > 1) document.cookie = 'pixelRatio=' + window.devicePixelRatio + ';path=/;expires=Tue, 19 Jan 2038 03:14:07 GMT';</script><link href="//fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700%7COpen+Sans+Condensed:700&amp;subset=latin,latin-ext,cyrillic,cyrillic-ext" rel="stylesheet"><link rel="apple-touch-icon-precomposed" href="/img/favicon/apple-touch-icon-precomposed.png"><link rel="canonical" href="https://javascript.info"><meta name="msapplication-TileColor" content="#222A2C"><meta name="msapplication-TileImage" content="/img/favicon/tileicon.png"> <link rel="icon" href="/img/favicon/favicon.png"><meta itemprop="image" content="https://javascript.info/img/logo_square_en.png"><meta property="og:title" content="The Modern Javascript Tutorial"><meta property="og:image" content="https://javascript.info/img/logo_square_en.png"><meta property="fb:admins" content="100001562528165"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="The Modern Javascript Tutorial"><meta name="twitter:site" content="@iliakan"><meta name="twitter:creator" content="@iliakan"><meta name="twitter:image" content="https://javascript.info/img/logo_square_en.png"><link href="/pack/styles.689cc33b38da05ad69b29fdcc4c4048f.css" rel="stylesheet"><script>window.GA_ID = "UA-2056213-15";</script><script>window.YANDEX_METRIKA_ID = 32184394;</script><script>!function(){window.GoogleAnalyticsObject="ga",window.ga=function(){window.ga.q.push(arguments)},window.ga.q=[],window.ga.l=Date.now(),ga("create",GA_ID,"auto"),window.currentUser&&ga("set","&uid",currentUser.id),window.addEventListener("error",function(e){var n=(e.filename||e.errorUrl)+": "+(e.lineno||e.errorLine),r=e.stack||e.error&&e.error.stack;ga("send","exception",{exDescription:e.message+" "+n+" "+r,exFatal:!0})})}();</script><script src="//www.google-analytics.com/analytics.js" async></script><script>ga('send', 'pageview');</script><script>!function(){window.metrika={reachGoal:function(){}},window.yandex_metrika_callbacks=[function(){try{window.metrika=new Ya.Metrika({id:YANDEX_METRIKA_ID,webvisor:!0,clickmap:!0,params:{user:window.currentUser&&window.currentUser.id}}),metrika.trackLinks({delay:150}),window.addEventListener("error",function(r){window.metrika.reachGoal("JSERROR",{src:(r.filename||r.errorUrl)+": "+(r.lineno||r.errorLine),stack:r.stack||r.error&&r.error.stack,message:r.message})})}catch(r){}}]}();</script><script src="//mc.yandex.ru/metrika/watch.js" async></script><script>//- hitCallback will never work, but that must be worked around by gaHitCallback wrapper
window.ga = function() {};</script><script>window.metrika = { reachGoal: function() {} };</script><script>window.RECAPTCHA_ID = "6Lf9NyETAAAAACZlg-a9Us2SxvYbeVC1ROWaWv4O";</script><script src="/pack/head.861a58399318987c3f3d.js"></script><script src="/pack/tutorial.861a58399318987c3f3d.js" defer></script><meta name="description" content="Modern JavaScript Tutorial: simple, but detailed explanations with examples and tasks, including: closures, document and events, object oriented programming and more."><script src="/pack/footer.861a58399318987c3f3d.js" defer></script></head><body class="no-icons"><script>head.fontTest();</script><div class="page-wrapper"><div class="page"><script>if(localStorage.noSidebar){document.querySelector(".page").classList.remove("page_sidebar_on");var pageWrapper=document.querySelector(".page-wrapper");pageWrapper&&pageWrapper.classList.remove("page-wrapper_sidebar_on")}setTimeout(function(){document.querySelector(".page").classList.add("page_sidebar-animation-on")},0);</script><div class="main-en-banner"><a href="/" class="main-en-banner__logo"><img src="/img/logo-en-white.svg" width="194" alt=""></a><div class="main-en-banner__inner"><div class="main-en-banner__texts"><h1 class="main-en-banner__title">The Modern JavaScript Tutorial</h1><p class="main-en-banner__text">How it's done now. From the basics to advanced topics with simple, but detailed explanations.</p></div><a href="https://github.com/iliakan/javascript-tutorial-en" class="main-en-banner__github">view on Github</a><div class="main-en-banner__content"><form action="/search/" class="main-en-search"><input type="search" name="query" placeholder="Search in the tutorial" required class="main-en-search__input"><button type="submit" name="type" value="articles" class="main-en-search__button">Search</button></form></div><div class="main-en-banner__sub"><h2 class="main-en-banner__subtitle">Table of contents</h2><p class="main-en-banner__text">Main course contains 2 parts which cover JavaScript as a programming language and working with a browser. There are also additional series of thematic articles.</p></div></div></div><div class="page__inner"><main class="main main_width-limit-wide"><div class="content frontpage"><div class="main-en-contents"><div class="main-en-contents__container"><div class="main-en-contents__inner"><div class="main-en-contents__part">PART 1</div><div class="main-en-contents__title">The JavaScript language</div><div class="main-en-contents__description"><p>Here we learn JavaScript, starting from scratch and go on to advanced concepts like OOP.</p>
<p>We concentrate on the language itself here, with the minimum of environment-specific notes.</p>
</div><div class="list"><div class="list__item"><div class="list__title"><a href="/getting-started" class="list__link">An introduction</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/intro" class="list-sub__link">An introduction to JavaScript</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/code-editors" class="list-sub__link">Code editors</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/devtools" class="list-sub__link">Developer console</a></div></li></ul></div><div class="list__item"><div class="list__title"><a href="/first-steps" class="list__link">JavaScript Fundamentals</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/hello-world" class="list-sub__link">Hello, world!</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/structure" class="list-sub__link">Code structure</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/strict-mode" class="list-sub__link">The modern mode, &quot;use strict&quot;</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/variables" class="list-sub__link">Variables</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/types" class="list-sub__link">Data types</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/type-conversions" class="list-sub__link">Type Conversions</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/operators" class="list-sub__link">Operators</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/comparison" class="list-sub__link">Comparisons</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/alert-prompt-confirm" class="list-sub__link">Interaction: alert, prompt, confirm</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/ifelse" class="list-sub__link">Conditional operators: if, '?'</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/logical-operators" class="list-sub__link">Logical operators</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/while-for" class="list-sub__link">Loops: while and for</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/switch" class="list-sub__link">The &quot;switch&quot; statement</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/function-basics" class="list-sub__link">Functions</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/function-expressions-arrows" class="list-sub__link">Function expressions and arrows</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/javascript-specials" class="list-sub__link">JavaScript specials</a></div></li><div class="list-sub__more">More…</div></ul></div><div class="list__item"><div class="list__title"><a href="/code-quality" class="list__link">Code quality</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/debugging-chrome" class="list-sub__link">Debugging in Chrome</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/coding-style" class="list-sub__link">Coding style</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/comments" class="list-sub__link">Comments</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/ninja-code" class="list-sub__link">How to write bad code?</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/testing-mocha" class="list-sub__link">Automated testing with mocha</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/polyfills" class="list-sub__link">Polyfills</a></div></li></ul></div><div class="list__item"><div class="list__title"><a href="/object-basics" class="list__link">Objects: the basics</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/object" class="list-sub__link">Objects</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/garbage-collection" class="list-sub__link">Garbage collection</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/symbol" class="list-sub__link">Symbol type</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/object-methods" class="list-sub__link">Object methods, &quot;this&quot;</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/object-toprimitive" class="list-sub__link">Object to primitive conversion</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/constructor-new" class="list-sub__link">Constructor, operator &quot;new&quot;</a></div></li></ul></div><div class="list__item"><div class="list__title"><a href="/data-types" class="list__link">Data types</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/primitives-methods" class="list-sub__link">Methods of primitives</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/number" class="list-sub__link">Numbers</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/string" class="list-sub__link">Strings</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/array" class="list-sub__link">Arrays</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/array-methods" class="list-sub__link">Array methods</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/iterable" class="list-sub__link">Iterables</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/map-set-weakmap-weakset" class="list-sub__link">Map, Set, WeakMap and WeakSet</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/keys-values-entries" class="list-sub__link">Object.keys, values, entries</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/destructuring-assignment" class="list-sub__link">Destructuring assignment</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/date" class="list-sub__link">Date and time</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/json" class="list-sub__link">JSON methods, toJSON</a></div></li><div class="list-sub__more">More…</div></ul></div><div class="list__item"><div class="list__title"><a href="/advanced-functions" class="list__link">Advanced working with functions</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/recursion" class="list-sub__link">Recursion and stack</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/rest-parameters-spread-operator" class="list-sub__link">Rest parameters and spread operator</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/closure" class="list-sub__link">Closure</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/var" class="list-sub__link">The old &quot;var&quot;</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/global-object" class="list-sub__link">Global object</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/function-object" class="list-sub__link">Function object, NFE</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/new-function" class="list-sub__link">The &quot;new Function&quot; syntax</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/settimeout-setinterval" class="list-sub__link">Scheduling: setTimeout and setInterval</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/call-apply-decorators" class="list-sub__link">Decorators and forwarding, call/apply</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/bind" class="list-sub__link">Function binding</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/currying-partials" class="list-sub__link">Currying and partials</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/arrow-functions" class="list-sub__link">Arrow functions revisited</a></div></li><div class="list-sub__more">More…</div></ul></div><div class="list__item"><div class="list__title"><a href="/object-oriented-programming" class="list__link">Objects, classes, inheritance</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/property-descriptors" class="list-sub__link">Property flags and descriptors</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/property-accessors" class="list-sub__link">Property getters and setters</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/prototype-inheritance" class="list-sub__link">Prototypal inheritance</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/function-prototype" class="list-sub__link">F.prototype</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/native-prototypes" class="list-sub__link">Native prototypes</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/prototype-methods" class="list-sub__link">Methods for prototypes</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/class-patterns" class="list-sub__link">Class patterns</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/class" class="list-sub__link">Classes</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/class-inheritance" class="list-sub__link">Class inheritance, super</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/instanceof" class="list-sub__link">Class checking: &quot;instanceof&quot;</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/mixins" class="list-sub__link">Mixins</a></div></li><div class="list-sub__more">More…</div></ul></div><div class="list__item"><div class="list__title"><a href="/error-handling" class="list__link">Error handling</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/try-catch" class="list-sub__link">Error handling, &quot;try..catch&quot;</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/custom-errors" class="list-sub__link">Custom errors, extending Error</a></div></li></ul></div></div></div></div><div class="main-en-contents__container"><div class="main-en-contents__inner"><div class="main-en-contents__part">PART 2</div><div class="main-en-contents__title">Browser: Document, DOM, Interfaces</div><div class="main-en-contents__description"><p>Learning how to manage the browser page: add elements, manipulate their size and position, dynamically create interfaces and interact with the visitor.</p>
</div><div class="list"><div class="list__item"><div class="list__title"><a href="/document" class="list__link">Document</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/browser-environment" class="list-sub__link">Browser environment, specs</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/dom-nodes" class="list-sub__link">DOM tree</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/dom-navigation" class="list-sub__link">Walking the DOM</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/searching-elements-dom" class="list-sub__link">Searching: getElement* and querySelector*</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/basic-dom-node-properties" class="list-sub__link">Node properties: type, tag and contents</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/dom-attributes-and-properties" class="list-sub__link">Attributes and properties</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/modifying-document" class="list-sub__link">Modifying the document</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/styles-and-classes" class="list-sub__link">Styles and classes</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/size-and-scroll" class="list-sub__link">Element size and scrolling</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/size-and-scroll-window" class="list-sub__link">Window sizes and scrolling</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/coordinates" class="list-sub__link">Coordinates</a></div></li><div class="list-sub__more">More…</div></ul></div><div class="list__item"><div class="list__title"><a href="/events" class="list__link">Introduction into Events</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/introduction-browser-events" class="list-sub__link">Introduction to browser events</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/bubbling-and-capturing" class="list-sub__link">Bubbling and capturing</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/event-delegation" class="list-sub__link">Event delegation</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/default-browser-action" class="list-sub__link">Browser default actions</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/dispatch-events" class="list-sub__link">Dispatching custom events</a></div></li></ul></div><div class="list__item"><div class="list__title"><a href="/event-details" class="list__link">Events in details</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/mouse-events-basics" class="list-sub__link">Mouse events basics</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/mousemove-mouseover-mouseout-mouseenter-mouseleave" class="list-sub__link">Moving: mouseover/out, mouseenter/leave</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/mouse-drag-and-drop" class="list-sub__link">Drag'n'Drop with mouse events</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/keyboard-events" class="list-sub__link">Keyboard: keydown and keyup</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/onscroll" class="list-sub__link">Scrolling</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/onload-ondomcontentloaded" class="list-sub__link">Page lifecycle: DOMContentLoaded, load, beforeunload, unload</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/onload-onerror" class="list-sub__link">Resource loading: onload and onerror</a></div></li><div class="list-sub__more">More…</div></ul></div><div class="list__item"><div class="list__title"><a href="/forms-controls" class="list__link">Forms, controls</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/form-elements" class="list-sub__link">Form properties and methods</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/focus-blur" class="list-sub__link">Focusing: focus/blur</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/events-change-input" class="list-sub__link">Events: change, input, cut, copy, paste</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/forms-submit" class="list-sub__link">Form submission: event and method submit</a></div></li></ul></div></div></div></div><div class="main-en-contents__container"><div class="main-en-contents__inner"><div class="main-en-contents__part">PART 3</div><div class="main-en-contents__title">Additional articles</div><div class="main-en-contents__description">List of extra topics that are not covered by first two parts of tutorial. There is no clear hierarchy here, you can access articles in the order you want.</div><div class="list"><div class="list__item"><div class="list__title"><a href="/animation" class="list__link">Animation</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/bezier-curve" class="list-sub__link">Bezier curve</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/css-animations" class="list-sub__link">CSS-animations</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/js-animation" class="list-sub__link">JavaScript animations</a></div></li></ul></div><div class="list__item"><div class="list__title"><a href="/frames-and-windows" class="list__link">Frames and windows</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/popup-windows" class="list-sub__link">Popups and window methods</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/cross-window-communication" class="list-sub__link">Cross-window communication</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/clickjacking" class="list-sub__link">The clickjacking attack</a></div></li></ul></div><div class="list__item"><div class="list__title"><a href="/regular-expressions" class="list__link">Regular expressions</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/regexp-introduction" class="list-sub__link">Patterns and flags</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/regexp-methods" class="list-sub__link">Methods of RegExp and String</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/regexp-character-classes" class="list-sub__link">Character classes</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/regexp-escaping" class="list-sub__link">Escaping, special characters</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/regexp-character-sets-and-ranges" class="list-sub__link">Sets and ranges [...]</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/regexp-unicode" class="list-sub__link">The unicode flag</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-quantifiers" class="list-sub__link">Quantifiers +, *, ? and {n}</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-greedy-and-lazy" class="list-sub__link">Greedy and lazy quantifiers</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-groups" class="list-sub__link">Capturing groups</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-backreferences" class="list-sub__link">Backreferences: \n and $n</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-alternation" class="list-sub__link">Alternation (OR) |</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-anchors" class="list-sub__link">String start ^ and finish $</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-multiline-mode" class="list-sub__link">Multiline mode, flag &quot;m&quot;</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-lookahead" class="list-sub__link">Lookahead (in progress)</a></div></li><li class="list-sub__item list-sub__item_phone_hidden"><div class="list-sub__title"><a href="/regexp-infinite-backtracking-problem" class="list-sub__link">Infinite backtracking problem</a></div></li><div class="list-sub__more">More…</div></ul></div><div class="list__item"><div class="list__title"><a href="/async" class="list__link">Promises, async/await</a></div><ul class="list-sub"><li class="list-sub__item"><div class="list-sub__title"><a href="/callbacks" class="list-sub__link">Introduction: callbacks</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/promise-basics" class="list-sub__link">Promise</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/promise-chaining" class="list-sub__link">Promises chaining</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/promise-api" class="list-sub__link">Promise API</a></div></li><li class="list-sub__item"><div class="list-sub__title"><a href="/async-await" class="list-sub__link">Async/await</a></div></li></ul></div></div></div></div></div><script type="application/ld+json">{
  "@context": "http://schema.org",
  "@type": "WebSite",
  "url": "https://javascript.info/",
  "potentialAction": {
    "@type": "SearchAction",
    "target": "https://javascript.info/search?query={search_term_string}",
    "query-input": "required name=search_term_string"
  }
}</script></div><div id="comments" class="comments"><div class="comments__header"><h2 class="comments__header-title"><a href="#comments" name="comments">Comments</a></h2><div class="comments__read-before"><span class="comments__read-before-link">read this before commenting…</span><div class="comments__read-before-popup"><div class="comments__read-before-popup-i"><ul><li>You're welcome to post additions, questions to the articles and answers to them.</li><li>To insert a few words of code, use the <code>&lt;code&gt;</code> tag, for several lines – use <code>&lt;pre&gt;</code>, for more than 10 lines – use a sandbox (<a href='http://plnkr.co/edit/?p=preview'>plnkr</a>, <a href='http://jsbin.com'>JSBin</a>, <a href='http://codepen.io'>codepen</a>…)</li><li>If you can't understand something in the article – please elaborate.</li></ul></div></div></div></div></div><div id="disqus_thread"></div><script>var disqus_config = function() { if (!this.page) this.page = {}; Object.assign(this.page, {"url":"https:\/\/javascript.info","identifier":"","title":"The Modern Javascript Tutorial"}); };</script><script>var disqus_shortname = "javascriptinfo";</script><script>{
  var s = document.createElement('script');
  s.src = '//' + disqus_shortname + '.disqus.com/embed.js';
  s.setAttribute('data-timestamp', +new Date());
  document.head.appendChild(s);
}
</script><script async id="dsq-count-scr" src="//javascriptinfo.disqus.com/count.js"></script></main></div></div></div><div class="page-footer"><div class="page-footer__left"><ul class="page-footer__list"><li class="page-footer__item">©&nbsp;2007—2017&nbsp; Ilya Kantor</li><li class="page-footer__item"><a href="/about#contact-us" class="page-footer__link">contact us</a></li><li class="page-footer__item"><a href="/about" class="page-footer__link">about the project</a></li><li class="page-footer__item"><a href="https://learn.javascript.ru" class="page-footer__link">RU</a> / EN</li></ul></div><div class="page-footer__right"><ul class="page-footer__list"><li class="page-footer__item">powered by <a rel="nofollow" href="http://nodejs.org" class="page-footer__link">node.js</a>&nbsp;&amp;&nbsp;<a rel="nofollow" href="http://github.com/iliakan/javascript-tutorial-ru" class="page-footer__link">open source</a></li></ul></div></div></body></html>